Android Studio Error: Error:CreateProcess error=216, This version of %1 is not compatible with the version of Windows you’re running

By | August 4, 2019

Question

Installed Android Studio 2.2 Preview 2 and getting this error:

Error:CreateProcess error=216, This version of %1 is not compatible with the version of Windows you’re running. Check your computer’s system information and then contact the software publisher

Screenshot:
enter image description here

I re-installed the JDK, still same issue.

I even tried to use the embedded JDK but still having the same issue:

enter image description here

Solution

I had the same issue, but I have resolved it the next:

1) Install jdk1.8…

2) In AndroidStudio File->Project Structure->SDK Location, select your directory where the JDK is located, by default Studio uses embedded JDK but for some reason it produces error=216.

3) Click Ok.

Rate this post

Leave a Reply

Your email address will not be published. Required fields are marked *